复制链接

扫一扫

[插件]远程代码执行

说明:获取远程服务器动态常量变量

源码类型:纯源码可二开

开发者:bsphp官方

插件下载

bsphp.bj.bcebos.com/Plug/%E8%BF%9C%E7%A8%8B%E5%8A%A8%E6%80%81%E5%8F%98%E9%87%8F%E6%8F%92%E4%BB%B6%E7%BA%AF%E6%BA%90%E7%A0%81.zip

安装说明:直接根目录覆盖即可,后台》运营插件》远程变量常量插件

API详情
名称:远程代码执行
API:RemoteVariable.in
说明:通过一些代码在服务器执行计算,可以防御部分人破解,给破解加分
返回说明:返回远程代码计算内容
参数
说明
注释
&api=API接口名称必填
&BSphpSeSsL=BSphpSeSsL连接Cookies必填
&date=服务器时间超时验证可空,后台设置超时0就是关闭
&md5=程序MD5可空,后台MD5内容要为空
&mutualkey=通信认证Key必填,用作软件数据包交换数据验证串
&appsafecode=封包劫持检测可空,客户端提交参数给服务器时候原样返回
&sgin=签名验证可空,详情看签名验证规则
&code=执行代码ID32位值
&c=自定义传递参数自己需要参数参考案例

API参数信息:

&api=RemoteVariable.in

&code=[后台唯一code标识]

易语言SDK代码

.版本 2

.子程序 获取远程变量, 文本型, 公开, 返回状态信息
.参数 code, 文本型

返回 (发送协议 (“&api=RemoteVariable.in&code=” + code))

.子程序 获取远程变量_自定义参数c, 文本型, 公开, 返回状态信息
.参数 code, 文本型
.参数 c, 文本型

返回 (发送协议 (“&api=RemoteVariable.in&code=” + code + “&c=” + c))

URL带参数http://xxxxx/Plug/RemoteVariable.php?code=d0e84f1d52c58a1de9436b71bc133305&c=1

调试过程图片参考